flight controller

More
1 year 1 month ago #2543 by Sukafree
I have everything connected but the motors wouldn't turn on. What step did I miss?

waiting for something good......
Attachments:

Please Log in to join the conversation.

More
1 year 1 month ago #2544 by MaydayJoey
Is there only a red light? or is there a green/flashing light?

Are you arming it with your controller?

Please make sure you introduce yourself in the first thread.
---- Here: bayrc.net/forum/welcome-mat/2-mayday-joe...ome-to-the-new-bayrc

Please Log in to join the conversation.

More
1 year 1 month ago #2547 by Sukafree
There's a green and red light when it first comes on then a solid red after it binds. I tried moving the sticks left then right, one then both and nothing

waiting for something good......

Please Log in to join the conversation.

More
1 year 1 month ago #2548 by MaydayJoey
I don't know the controller. Do you know what the steps are to ARM and DISARM it?

Have you been able to plug it in and update it? Check settings etc.

Please make sure you introduce yourself in the first thread.
---- Here: bayrc.net/forum/welcome-mat/2-mayday-joe...ome-to-the-new-bayrc

Please Log in to join the conversation.

More
1 year 1 month ago #2553 by Sukafree
I plugged it in and backed it up then updated the firmware on clean flight, bind it to my rx and still nothing

waiting for something good......

Please Log in to join the conversation.

More
1 year 1 month ago - 1 year 1 month ago #2554 by Moybzz
maybe try lowering the throttle trim setting and increase pitch, roll, and yaw on radio to 125%.
Last Edit: 1 year 1 month ago by Moybzz.

Please Log in to join the conversation.

Time to create page: 0.313 seconds
Powered by Kunena Forum